Jump to content
InvisionCommunity.de - Der Deutsche Invision Community Support

Hunter

Mitglied
  • Content count

    30
  • Joined

  • Last visited

About Hunter

  • Rank
    Grünschnabel
  • Birthday 26.08.1981

IP.Board Informationen

  • IP.Board Version
    1.3.x

Contact Methods

  • Website URL
    http://
  • ICQ
    0
  1. Version

    64 downloads

    Grüß Euch So, da ich hier vor einigen Tagen aufgrund der neuen Auswirkungen des Karlsruher BGH-Urteils vom März 2004 (welches Internet-Foren und Gästebücher gefährdet, weil sie für den Content der Foren rechtlich belangt werden könnten) für meine Community neue Nutzungsbedingungen geschrieben habe, hab ich mich auch gleich an das Schreiben einer kompletten Forennetiquette gemacht. Wer nicht sofort weiß, was man unter Netiquette versteht, der kann sich hier einen kleinen Einblick verschaffen: Wikipedia.org Da das Board bereits boardeigene Funktionen mitbringt, um Nutzungsbedingungen oder Regeln in das Board zu integrieren, muss man sich hier nicht viel Mühe machen: Entweder man benutzt die Funktion über: -> System Settings ---> Board Guidelines oder (wie ich es gemacht habe) teilt Netiquette und Nutzungsbedinungen in zwei Teile, wobei die Nutzungsbedinungen unter die 1. Möglichkeit von oben fallen und für die Netiquette ein eigener Link in die Boardleiste oben eingefügt wird. Beschrieben wird dies hier im Forum von Rigo. Doch da das alles nicht neu ist, wollte ich Euch meine Nutzungsbedinungen und meine Netiquette zur Verfügung stellen. Ich denke insbesondere die Netiquette dürfte ganz gut gelungen sein, die Nutzungsbedinungen wiederholen sich vom Sinn her ab und an, doch dies ist notwendig. Beide sind in einem Word-Dokument im Anhang enthalten. Ich habe eigentlich alles, was sehr speziell ist und sich lediglich auf unser "Rollenspielforum" bezieht bereits herausgelöscht; doch sollte sich jeder den Inhalt nochmal selbst durchlesen. Solltet Ihr also daran Interesse haben, einfach runterladen und nutzen. Gruß Hunter
  2. Dateiname: Netiquette und Nutzungsbedinungen Dateisender: Hunter Datei eingesendet: 19 Oct 2006 Datei zuletzt bearbeitet: 19 Oct 2006 Dateikategorie: Modifikationen 1.3 Grüß Euch So, da ich hier vor einigen Tagen aufgrund der neuen Auswirkungen des Karlsruher BGH-Urteils vom März 2004 (welches Internet-Foren und Gästebücher gefährdet, weil sie für den Content der Foren rechtlich belangt werden könnten) für meine Community neue Nutzungsbedingungen geschrieben habe, hab ich mich auch gleich an das Schreiben einer kompletten Forennetiquette gemacht. Wer nicht sofort weiß, was man unter Netiquette versteht, der kann sich hier einen kleinen Einblick verschaffen: Wikipedia.org Da das Board bereits boardeigene Funktionen mitbringt, um Nutzungsbedingungen oder Regeln in das Board zu integrieren, muss man sich hier nicht viel Mühe machen: Entweder man benutzt die Funktion über: -> System Settings ---> Board Guidelines oder (wie ich es gemacht habe) teilt Netiquette und Nutzungsbedinungen in zwei Teile, wobei die Nutzungsbedinungen unter die 1. Möglichkeit von oben fallen und für die Netiquette ein eigener Link in die Boardleiste oben eingefügt wird. Beschrieben wird dies hier im Forum von Rigo. Doch da das alles nicht neu ist, wollte ich Euch meine Nutzungsbedinungen und meine Netiquette zur Verfügung stellen. Ich denke insbesondere die Netiquette dürfte ganz gut gelungen sein, die Nutzungsbedinungen wiederholen sich vom Sinn her ab und an, doch dies ist notwendig. Beide sind in einem Word-Dokument im Anhang enthalten. Ich habe eigentlich alles, was sehr speziell ist und sich lediglich auf unser "Rollenspielforum" bezieht bereits herausgelöscht; doch sollte sich jeder den Inhalt nochmal selbst durchlesen. Solltet Ihr also daran Interesse haben, einfach runterladen und nutzen. Gruß Hunter Hier klicken um diese Datei herunterzuladen
  3. [Archiv] [MOD] Open-Poll

    Nein, daran lag es nicht; habe eben den Fehler gefunden: Und zwar hast Du oben geschrieben: Suche das: Füge davor das ein: -> hatte ich auch gemacht; doch ergänze in der Anleitung bitte noch, dass man dies 2 Mal suchen und jeweils mit den 3 Zeilen erweitern muss Danach war die Fehlermeldung verschwunden und es klappte wunderbar. Und das hier: kommt bei mir nur einmal in der Topics.php vor, doch was solls, es funktioniert ja nun einwandfrei. Vielen Dank für diesen tollen Mod Hunter
  4. [Archiv] [MOD] Open-Poll

    So, ich hab die ganze Funktion jetzt auch noch einmal eingebaut, konnte ich mir ja nicht nehmen lassen Der Mod funktioniert tatsächlich; soweit ich das aktuell überblicken kann. Ich kann Abstimmungen erstellen, ich kann Abstimmen und ich bekomme das Ergebnis bisher richtig angezeigt. Ein kleiner Fehler scheint aber noch zu existieren, zumindest bei mir: Warning: Missing argument 2 for show_total_votes() in /sources/functions.php(649) : eval()'d code on line 2 Hab hier leider aktuell keinen Zugriff auf den FTP-Server, doch werd ich die functions-Zeile hier noch reinposten. Das nur mal als Vorabinfo, falls auch so schon jemand die Lösung weiß. Lieben Gruß und vielen Dank schonmal an Black Hunter
  5. Danke für die damalige Hilfe! Hatte soeben das gleiche Problem und mich eben im Code schon blöde gesucht und einfach nicht verstanden, warum plötzlich der ganze Kalender nicht mehr angezeigt wurde. Für alle, die also zufällig das gleiche Problem haben sollen: das ist die Lösung. :P
  6. [Archiv] [MOD] Open-Poll

    Hmm, hab den ganzen Mist wieder ausgebaut, funktioniert einfach nicht, egal was ich versuche. Die Topics.php hast Du, solltest Du irgendwann wieder Lust bekommen, weiterzubasteln, gib einfach bescheid. Lieben Gruß und trotzdem Danke für die Hilfe Hunter
  7. [Archiv] [MOD] Open-Poll

    Hmm, jetzt sind wir genauso weit wie am Anfang: Es funktioniert, eine Umfrage zu erstellen; doch leider wird sie (und damit die Ergebnisse) nicht angezeigt. Lediglich die zwei Buttons zum Abstimmen bzw. sich das Ergebnis anzuschauen sind vorhanden, reagieren aber logischerweise auf kein Klicken, da keine Auswahl getroffen wurde (wie auch, wenn diese nicht angezeigt wird). Fehlermeldung existiert keine. ------- Edit: P.S.: Hatte die Klammern auch abgezählt, scheine mich aber verzählt zu haben (hatte nämlich testweise eine andere rausgenommen gehabt). Da damit der Fehler nicht behoben war und ich mir eigentlich recht sicher war und nach dem zweiten Abzählen wieder auf das gleiche Ergebnis kam, ging ich davon aus, dass der Fehler wo anders zu finden sein muss. (weiß nun auch woran es lag: hatte eine öffnende Klammer nicht mitgezählt, die noch an eine Zeile hinten dran geklatscht war) Wollte hier niemanden als Klammer-Editor "missbrauchen", sorry. :(
  8. [Archiv] [MOD] Open-Poll

    So, Mod wieder aus und wieder neu eingebaut, dass die Files auch ja sauber bleiben: Was ist mir aufgefallen? - post_poll_after.php wurde nicht bearbeitet, gibt daher wahrscheinlich eine Fehlermeldung beim Editieren (leider komme ich gar nicht so weit) - in der lang_topic (deutsche Version) ist ein Hochkomma-Fehler: Füge davor entweder dies: $lang[mod_public_poll_infos'] = "<b>ACHTUNG: Dies ist eine offene Umfrage und somit kann jeder sehen, wie du abgestimmt hast!</b>"; Läd man dann alles hoch, bekommt man folgende Fehlermeldung: Codestelle ist folgende (ich poste auch die 120 Zeilen davor mit, weil es sich bei der betreffenden Zeile um eine if-Abfrage (else-Zweig) handelt. //---------------------------------- // Have we voted in this poll? //---------------------------------- $DB->query("SELECT member_id from ibf_voters WHERE member_id=".$ibforums->member['id']." and tid=".$this->topic['tid']); $voter = $DB->fetch_row(); if ($voter['member_id'] != 0) { $check = 1; $poll_footer = $ibforums->lang['poll_you_voted']; } if ( ($poll_data['starter_id'] == $ibforums->member['id']) and ($ibforums->vars['allow_creator_vote'] != 1) ) { $check = 1; $poll_footer = $ibforums->lang['poll_you_created']; } if (! $ibforums->member['id'] ) { $check = 1; $poll_footer = $ibforums->lang['poll_no_guests']; } //---------------------------------- // is the topic locked? //---------------------------------- if ( $this->topic['state'] == 'closed' ) { $check = 1; $poll_footer = '&nbsp;'; } if ( $ibforums->vars['allow_result_view'] == 1 ) { if ( $ibforums->input['mode'] == 'show' ) { $check = 1; $poll_footer = ""; } } if ($check == 1) { //--------------------- // Show the results //--------------------- $total_votes = 0; $html = $this->poll_html->poll_header($this->topic['tid'], $poll_data['poll_question'], $edit_link, $delete_link); $poll_answers = unserialize(stripslashes($poll_data['choices'])); reset($poll_answers); foreach ($poll_answers as $entry) { $id = $entry[0]; $choice = $entry[1]; $votes = $entry[2]; $total_votes += $votes; if ( strlen($choice) < 1 ) { continue; } if ($ibforums->vars['poll_tags']) { $choice = $this->parser->parse_poll_tags($choice); } if ( $ibforums->vars['post_wordwrap'] > 0 ) { $choice = $this->parser->my_wordwrap( $choice, $ibforums->vars['post_wordwrap']); } $percent = $votes == 0 ? 0 : $votes / $poll_data['votes'] * 100; $percent = sprintf( '%.2f' , $percent ); $width = $percent > 0 ? (int) $percent * 2 : 0; // Start Mod Public Polls if ($poll_data['status'] == 1) { $mod_voted = $ibforums->lang['mod_public_poll_voters']; foreach ($mod_choices as $mod_member_id => $mod_voting_info) { if ( ($mod_voting_info['vote'] == $id) && $mod_voting_info['vote'] != "-1") { $mod_voted .= "<a href='{$this->base_url}showuser={$mod_member_id}'>{$mod_voting_info[name]}</a>, "; unset($mod_choices[$mod_member_id]); } } $mod_voted = preg_replace("#,$#", "", $mod_voted); } $html .= $this->poll_html->Render_row_results($votes, $id, $choice, $percent, $width, $mod_voted); /* Start originaler Quelltext $html .= $this->poll_html->Render_row_results($votes, $id, $choice, $percent, $width); Ende originaler Quelltext */ } // End Mod Public Polls } if ($poll_data['status'] == 1) { $mod_voted = $ibforums->lang['mod_public_poll_novoters']; if (count($mod_choices) > 0) { foreach ($mod_choices as $mod_member_id => $mod_voting_info) { $mod_voted .= "<a href='{$this->base_url}showuser={$mod_member_id}'>{$mod_voting_info[name]}</a>, "; } } else { $mod_voted .= $ibforums->lang['mod_public_poll_novoters_info']; } $mod_voted .= "<br />"; $html = str_replace("<!--MOD_PUBLIC_POLL_NOVOTES-->", $mod_voted, $html); } // MOD ENDE } // ACHTUNG: DAS HIER IST DIE BETREFFENDE FEHLERZEILE 1913 else { $poll_answers = unserialize(stripslashes($poll_data['choices'])); reset($poll_answers); Die betreffende Fehlerzeile ist die 5. unterste Zeile "}" (markiert durch // ACHTUNG:)
  9. Jepp, kann ich bei Gelegenheit noch machen. ;)
  10. Grüß Euch So, da ich hier vor einigen Tagen aufgrund der neuen Auswirkungen des Karlsruher BGH-Urteils vom März 2004 (welches Internet-Foren und Gästebücher gefährdet, weil sie für den Content der Foren rechtlich belangt werden könnten) für meine Community neue Nutzungsbedingungen geschrieben habe, hab ich mich auch gleich an das Schreiben einer kompletten Forennetiquette gemacht. Wer nicht sofort weiß, was man unter Netiquette versteht, der kann sich hier einen kleinen Einblick verschaffen: Wikipedia.org Da das Board bereits boardeigene Funktionen mitbringt, um Nutzungsbedingungen oder Regeln in das Board zu integrieren, muss man sich hier nicht viel Mühe machen: Entweder man benutzt die Funktion über: -> System Settings ---> Board Guidelines oder (wie ich es gemacht habe) teilt Netiquette und Nutzungsbedinungen in zwei Teile, wobei die Nutzungsbedinungen unter die 1. Möglichkeit von oben fallen und für die Netiquette ein eigener Link in die Boardleiste oben eingefügt wird. Beschrieben wird dies hier im Forum von Rigo. Doch da das alles nicht neu ist, wollte ich Euch meine Nutzungsbedinungen und meine Netiquette zur Verfügung stellen. Ich denke insbesondere die Netiquette dürfte ganz gut gelungen sein, die Nutzungsbedinungen wiederholen sich vom Sinn her ab und an, doch dies ist notwendig. Beide sind in einem Word-Dokument im Anhang enthalten. Ich habe eigentlich alles, was sehr speziell ist und sich lediglich auf unser "Rollenspielforum" bezieht bereits herausgelöscht; doch sollte sich jeder den Inhalt nochmal selbst durchlesen. Solltet Ihr also daran Interesse haben, einfach runterladen und nutzen. Gruß Hunter WICHTIG: Der neue Download befindet sich hier. Das Hilfe Thema zu diesem Mod findest Du hier.
  11. [Archiv] [MOD] Open-Poll

    Nach Einbau aller Modifikationen von Black komme ich dann auf folgende Fehlermeldung im Board (beim Erstellen einer neuen Umfrage): In den vermeindlich fehlerhaften Codeteilen findet man: post_poll.php // Start Mod Public Polls 'status' => ($ibforums->input['open_poll'] == 1) ? 1 : 0, // End Mod Public Polls Post.php $post_functions = new post_functions(&$this); Neue Ideen, Vorschläge?
  12. [Archiv] [MOD] Open-Poll

    Klar wurden beide gemacht; doch ist mir beim erneuten Kompletteinbau ein Fehler aufgefallen. Nach Gebrauchsanweisung soll folgendes getan werden: In der Datei skin_poll.php ist mir noch etwas aufgefallen, ein Unterschied zwischen Gebrauchsanleitung und eigentlichem Quellcode des Boards: Mod-Anleitung: Suche: function Render_row_results($votes, $id, $answer, $percentage, $width) { global $ibforums; return << <tr> <td class='row1'>$answer</td> <td class='row1'> [ <b>$votes</b> ] </td> <td class='row1' align='left'><img src='{$ibforums->vars['img_url']}/bar_left.gif' border='0' width='4' height='11' align='middle' alt='' /><img src='{$ibforums->vars['img_url']}/bar.gif' border='0' width='$width' height='11' align='middle' alt='' /><img src='{$ibforums->vars['img_url']}/bar_right.gif' border='0' width='4' height='11' align='middle' alt='' /> [$percentage%]</td> </tr> EOF; } Im Quellcode des Boards ist es aber so hinterlegt: function Render_row_results($votes, $id, $answer, $percentage, $width) { global $ibforums; return <<<EOF <tr> <td class='row1'>$answer</td> <td class='row1'> [ <b>$votes</b> ] </td> <td class='row1' align='left'><img src='{$ibforums->vars['img_url']}/bar_left.gif' border='0' width='4' height='11' align='middle' alt='' /><img src='{$ibforums->vars['img_url']}/bar.gif' border='0' width='$width' height='11' align='middle' alt='' /><img src='{$ibforums->vars['img_url']}/bar_right.gif' border='0' width='4' height='11' align='middle' alt='' /> &nbsp;[$percentage%]</td> </tr> EOF; } Man beachte die 4. Zeile! Daher müßte es (nach meiner Auffassung) richtig heißen: function Render_row_results($votes, $id, $answer, $percentage, $width, $voted = "") { global $ibforums; return <<<EOF <tr> <td class='row1'>$answer</td> <td class='row1'> [ <b>$votes</b> ] </td> <td class='row1' align='left'><img src='{$ibforums->vars['img_url']}/bar_left.gif' border='0' width='4' height='11' align='middle' alt='' /><img src='{$ibforums->vars['img_url']}/bar.gif' border='0' width='$width' height='11' align='middle' alt='' /><img src='{$ibforums->vars['img_url']}/bar_right.gif' border='0' width='4' height='11' align='middle' alt='' />&nbsp;[$percentage%]{$voted}</td> </tr> EOF; } Beim der nächsten Änderung in der gleichen Datei genauso: Suche: function show_total_votes($total_votes) { global $ibforums; return << <tr> <td class='row1' colspan='3' align='center'><strong>{$ibforums->lang['pv_total_votes']}: $total_votes</strong></td> </tr> EOF; } Ersetze durch: function show_total_votes($total_votes) { global $ibforums; return << <tr> <td class='row1' colspan='3' align='center'><!--MOD_PUBLIC_POLL_NOVOTES--><strong>{$ibforums->lang['pv_total_votes']}: $total_votes</strong></td> </tr> EOF; } -> daher auch hier wieder gleicher Fehler (in 3. Zeile), ergo müßte es so aussehen: function show_total_votes($total_votes) { global $ibforums; return <<<EOF <tr> <td class='row1' colspan='3' align='center'><!--MOD_PUBLIC_POLL_NOVOTES--><strong>{$ibforums->lang['pv_total_votes']}: $total_votes</strong></td> </tr> EOF; }
  13. :rolleyes: Prima, vielen Dank TomCrow. Es lag tatsächlich daran. Blöderweise habe ich noch selbst flüchtig darüber nachgedacht, ob es diese Funktion sein kann; dachte aber sofort im gleichen Moment (beeinflusst durch das angegebene Beispiel), dass es daran bestimmt nicht liegt! -> Denn schließlich folgen ja keine Großbuchstaben aufeinander, es befinden sich nur zwei in quasi einem Wort. Blöd... Wie dem auch sei, danke für debn Tipp! ;)
  14. Grüß Euch So, mein Titel mag sehr abenteuerlich erscheinen, doch drückt er nur aus, was ich vorhabe. Vielleicht ist es den meisten von Euch noch gar nicht aufgefallen, doch sobald man im Board einen neuen Thread anlegt und im Titel folgende Kombination an Wörtern eingibt: - "Wort1-Wort2" als Beispiel "Auto-Thread" - "Wort1 wort2 wort3" als Beispiel "habe heute frei" oder "Wie sieht es mit xyz aus?" dann kommen ganz böse Sachen dabei raus, weil irgend eine Funktion des englischen IVBs hergeht, den String analysiert und verändert in folgender Form (auf Groß- und Kleinschreibung achten): - "Auto-thread" - "Habe Heute Frei" / "Wie Sieht Es Mit xyz Aus?" Gibt es ne Möglichkeit, das auszuschalten bzw. sonstwie zu unterbinden? Wenn nein, hat jemand ne Ahnung, wie und wo ich diese Funktion "herausdoktern" kann? Ich komme darauf, weil es nicht nur mir, sondern bereits auch 2 Usern aufgefallen ist und ich gefragt wurde, ob ich das nicht abstellen kann. Gruß und grinsend, weil ich nicht weiß, wievielen das schon aufgefallen ist Hunter ----------------- Edit: Bei Euch im Board funktioniert das ja richtig, bemerke ich gerade... !?!
  15. Wie ich mit Schrecken feststellen musste, gibt es ibplanet.com nicht mehr; die Seite linkt weiter auf die Invision-Board Homepage... hat demnach noch einer von Euch zufällig den Mod in Rohform bzw. die Gebrauchsanleitung bei sich herumfliegen und könnte die hier hochladen? Zwar gibt es hier noch ein anderes Thema mit gleichem Inhalt, jedoch mit anderem Link. Doch leider funzt der auch nicht, zumindest aktuell... (der eine invisionize.com, der andere ibplanet.com); beide down (ibplanet wohl für immer, invisionize wahrscheinlich temporär, weiß ich aber nicht genau). Liebe Grüße und schonmal vielen Dank Hunter
×